Nos obligan a molestarte con la obviedad de que este sitio usa cookies OK | Más información
receptor viark

Chincheta Autor Tema: problemas jtag antes de conectar  (Leído 3233 veces)

10/02/2013, 11:35

Desconectado cuchares

messageicon

problemas jtag antes de conectar

« en: 10/02/2013, 11:35 »
Hola a todos:
                         Como a muchos, al quedar en booting eterno he leido todo y probado otras alternativas que no han funcionado. Despues de construir el jtag adecuado, siguiendo el manual, y antes de conectar el azbox llego a esta situación


config.status: creating config.h
config.status: config.h is unchanged
config.status: executing depfiles commands
config.status: executing libtool commands
root@misco-HP-dc5000-SFF-PK928UC:~/AZBOX/openocd-0.4.0# make
make  all-recursive
make[1]: se ingresa al directorio «/root/AZBOX/openocd-0.4.0»
Making all in src
make[2]: se ingresa al directorio «/root/AZBOX/openocd-0.4.0/src»
make  all-recursive
make[3]: se ingresa al directorio «/root/AZBOX/openocd-0.4.0/src»
Making all in helper
make[4]: se ingresa al directorio «/root/AZBOX/openocd-0.4.0/src/helper»
make  all-am
make[5]: se ingresa al directorio «/root/AZBOX/openocd-0.4.0/src/helper»
/bin/bash ../../libtool --tag=CC   --mode=compile gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I../..  -I../../src -I../../src -DPKGDATADIR=\"/usr/local/share/openocd\"   -g -O2 -Wall -Wstrict-prototypes -Wformat-security -Wextra -Wno-unused-parameter -Wbad-function-cast -Wcast-align -Wredundant-decls -Werror -MT libhelper_la-jim.lo -MD -MP -MF .deps/libhelper_la-jim.Tpo -c -o libhelper_la-jim.lo `test -f 'jim.c' || echo './'`jim.c
libtool: compile:  gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I../.. -I../../src -I../../src -DPKGDATADIR=\"/usr/local/share/openocd\" -g -O2 -Wall -Wstrict-prototypes -Wformat-security -Wextra -Wno-unused-parameter -Wbad-function-cast -Wcast-align -Wredundant-decls -Werror -MT libhelper_la-jim.lo -MD -MP -MF .deps/libhelper_la-jim.Tpo -c jim.c -o libhelper_la-jim.o
jim.c: En la función ‘Jim_FormatString_Inner’:
jim.c:2248:23: error: se define la variable ‘_fmt’ pero no se usa [-Werror=unused-but-set-variable]
jim.c: En la función ‘SetScriptFromAny’:
jim.c:3059:13: error: se define la variable ‘interpolation’ pero no se usa [-Werror=unused-but-set-variable]
jim.c: En la función ‘Jim_PackageCoreCommand’:
jim.c:12179:13: error: se define la variable ‘exact’ pero no se usa [-Werror=unused-but-set-variable]
cc1: todos los avisos se tratan como errores
make[5]: *** [libhelper_la-jim.lo] Error 1
make[5]: se sale del directorio «/root/AZBOX/openocd-0.4.0/src/helper»
make[4]: *** [all] Error 2
make[4]: se sale del directorio «/root/AZBOX/openocd-0.4.0/src/helper»
make[3]: *** [all-recursive] Error 1
make[3]: se sale del directorio «/root/AZBOX/openocd-0.4.0/src»
make[2]: *** [all] Error 2
make[2]: se sale del directorio «/root/AZBOX/openocd-0.4.0/src»
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio «/root/AZBOX/openocd-0.4.0»
make: *** [all] Error 2
root@misco-HP-dc5000-SFF-PK928UC:~/AZBOX/openocd-0.4.0#

y ya no puedo continuar. Soy totalmente inexperto en linux y no sé como resolverlo para poder seguir. Podríais ayudarme?. Gracias

10/02/2013, 11:45Respuesta #1

Desconectado cuchares

messageicon

Re: problemas jtag antes de conectar

« Respuesta #1 en: 10/02/2013, 11:45 »
Esto sucede después  de poner make tras seguir las siguientes secuencias en las que no tengo problemas

mkdir AZBOX
cd AZBOX
sudo apt-get install libftdi-dev libftdi1 libusb-dev
wget -c *ttp://download.berlios.de/openocd/openocd-0.4.0.tar.bz2
wget -c *ttp://download.pristavka.de/azboxhd/az3_nor_flash.rar (este creo que no hace ni falta porque en booting.zip de más adelante ya está el fichero, pero bueno...)
sudo apt-get install rar unrar
tar xjvf openocd-0.4.0.tar.bz2
unrar x az3_nor_flash.rar
cd openocd-0.4.0/
./configure --enable-dummy --enable-parport --enable-doxygen-pdf --enable-amtjtagaccel --enable-verbose --enable-ioutil --enable-zy100 --enable-x300t


¿A alguien le ha sucedido lo mismo?. ¿Cómo lo ha resuelto?. Gracias

11/02/2013, 17:16Respuesta #2

Desconectado cuchares

messageicon

Re: problemas jtag antes de conectar

« Respuesta #2 en: 11/02/2013, 17:16 »
¿no lo ha hecho nadie así?

 

GoogleTagged





PadreDeFamilia
!! ADVERTENCIAS !!: Las informaciones aquí publicadas NO CONTIENEN KEYS para la decodificación de ningún sistema: NO SON OPERATIVOS en sistemas SAT que precisen de su correspondiente suscripción. ESTA TOTALMENTE PROHIBIDO EL USO DE ESTAS INFORMACIONES PARA LA MODIFICACIÓN O DEFRAUDACIÓN DE SISTEMAS DE ACCESO CONDICIONAL. ESTOS FOROS SON MODERADOS Y NO SE PERMITE LA PUBLICACIÓN DE INFORMACIONES ILEGALES POR PARTE DE LOS USUARIOS. EN CASO DE DETECTARSE ESTE TIPO DE INFORMACIONES, LOS USUARIOS SERÁN EXCLUIDOS DE ESTAS PÁGINAS.
PROHIBIDA LA PUBLICACIÓN DE ENLACES A FIRMWARES ILEGALES